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Introduction

Successful integration of various information types is necessary for effective GIS (Geographic

Information Systems) analysis.  Take for example a company that needs to display potential

customers and competitors for a relocation decision. There are two ways to digitally create such a

map: (1) manually digitizing the locations onto a digital map of Charlottesville, or (2) address

matching.  Address matching is process of referencing a database of addresses with geographic

coordinates through geocoding. 

This step-by-step lesson will teach you how to successfully perform address matching using

ArcView 3.1.  First, you will learn the basic principles of address matching, identifying all the

necessary components.  In the next section, learn how to prepare, match and re-match addresses. 

Changes in data are covered in the last section, in addition to an example final output.  Within all

sections you will find examples and various ArcView windows that are commonly seen during

address matching.   If you need any further assistance, notify the information desk in the Geostat

Center in Alderman Library.

 

What You Need To Get Started

To begin, you will need:

v Table of addresses

v Shapefile containing the street network for the study area

Table of Addresses
After identifying the addresses that need to be matched for your project, find an associated table of

addresses.  An address table related your particular project may already exist.  Make sure that the

table adheres to the format guidelines listed below.  If there is no existing table, you can create your

own table using Excel. 
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Format Guidelines
Inside an Excel spreadsheet, begin by creating a separate column label for each location* field

(street address, city, state, and zip).  Next, enter each address, with one address per line.  The street

address should contain the address number + street name, in addition to street type and any

suffixes.  For example, “1581 Main St. N.W.” should all be within one cell. ArcView will recognize

intersections of roads using an ampersand (&) to describe the intersection, such as “15th St. & Page

St.”  Also include any other attributes needed to describe the project.  For instance, information on

gross sales, soil compositions, and population figures should all be placed in separate, labeled

columns.  When you are finished, the table of addresses must be one of the following two formats:

1) An ASCII text file with comma delimited field values and header row of field names

2) A dbase file (.dbf)

The dbase file format is most commonly used in ArcView and can be created through an existing

Excel spreadsheet. 

Converting Excel Tables (.xls) to dBase Format (.dbf)
To convert the address spreadsheet to a dbase file format:

Ø Open your Excel file (.xls) of addresses

Ø Highlight all cells to be converted

Ø Go to File > Save As, and choose the dbase IV format.

 A window explaining that information may be lost in the conversion will appear, click OK.

                                               
* Depending on your project, you may not need (or not be able to find) the entire address, which is acceptable in ArcView
3.1.
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Importing dBase Address Tables into ArcView
To Import a table into ArcView 3.1:

Ø Start ArcView 3.1

In the Untitled window, click once on the Tables icon, then select

Add

Ø In the Add Table window, select your file

You have now added your table to your ArcView project and are ready to proceed.  Here is an

example table of addresses (.dbf format) in ArcView 3.1.
                  

An example table of addresses in dbase (.dbf) format

imported into ArcView3.1

Street Network Theme
Theory of Geocoding
To geocode the addresses in your table, you need geographic data composed of indexed street

segments.  The area of interest must be contained within this theme.  In other words, you cannot

match Charlottesville addresses with a Chicago street network theme.  A finite range of addresses

found on a street plus its street name indexes each street in the interested area.   In ArcView, a

theme stores this indexed information. When matching addresses, ArcView first goes to the
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specified theme, then locates all the segments with the given street name.  Next, ArcView locates

the address range that contains the given address.  Within this street segment, ArcView calculates

the fractional location of the given address based on the address range and then places a marker on

that position.  Therefore, address matching is the approximation of where an address falls into a

given numerical range.  

Where to Find Themes
The Geostat Center has a wide variety of geographic data ready to use in address matching.  The

street network theme you choose will most likely be from TIGER census data.  If not, please

consult Geostat to make sure your file is acceptable for geocoding.  There are ways to cover the

entire U.S. within one street network theme.  One way is to use the StreetMap* extension in

ArcView 3.1. 

Importing Themes
To Import a theme into ArcView 3.1:

Ø In the Untitled window, click once on the Views icon, then

select New

A new window named View1 will appear. 

Go to View>Add Theme in the top menu bar or

select 

In the Add Theme window, select the .shp file

containing the specific street network

                                               
* Please see the guide “Address Matching Using StreetMap” for details.
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Your street network theme has now been added to your project.

To Display this theme:

Ø Select the small box to the left your theme in the

Legend of View1. 

Your street network theme should now appear in the View1 window.  Each theme has an associated

attribute table.  Below is an example attribute table of a street network theme (.shp) when opened

in ArcView3.1.

To open your street network theme table (not necessary for address matching, but as a check of

your data):

Ø Go to Theme>Table in the top menu bar or select

An example street network theme attribute table in ArcView 3.1
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Here is an example of an UNACCEPTABLE street network theme.  Although the theme consists
of street line segments, there are no left and right address ranges.  Also, there are indexes yet no
street names.  ArcView cannot perform address matching without street names and/or referenced
address ranges.

An example of an unacceptable street network theme attribute table in ArcView 3.1

 Address Matching

Geocoding
Building the Geocoding Index
After adding the appropriate address table and street network theme to your project, you are now

ready to geocode the addresses.  Make sure that the street network theme is active.  When active,

the theme name should appear raised in the legend.  To activate a theme, click once on the theme

name in the legend of View1. 

To Geocode a theme:

Ø Go to Theme>Properties at the top menu bar

Ø Select Geocoding from the left menu bar in the

Theme Properties window

This window establishes the street network theme address format.  Address Style controls the type

of address match.  The default, US Streets w/ Zone, will match addressing using the street address

and zip code.  Thus, zip code must be included in the address table. 
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To change the type of address match, select the format using the scroll down arrow.  Make sure

that your address table at least includes the fields necessary for the address style you have selected. 

Alias Table (not necessary) allows you to attach a table containing alternate names for streets and

addresses.  An example alias table would look like:

Route 66 = Main St.

Grant Park = 2702 State St.

The remaining entries in the window confirm the field names in the street network theme, and

need not be changed except for corrections. 

Ø Choose OK. 

The Building Geocoding Index window appears, confirming the address style format. 

Ø Select YES.

Linking the Address Table to the Street Network Theme

Ø Go back to View1. Make sure that the street network theme is still active. 

Ø Select View>Geocode Address from the top menu bar.

The Geocode Addresses window appears.  The Reference Theme entry

is the name of the street network theme to which you are geocoding. 

Join Field should remain at <none>.  If you would like

to change the type of address match, select the Change Address Style

button. 

Ø To link your table of addresses to the street theme, select   at

the right of Address Table, or type the path directly into the window.  Make sure that the

following windows (Address Field, Zone Field, etc.) are correct. 

The Display Field window controls the field to be used for display purposes with the mouse.  The

default name for your address locations is c:\temp\geocd1.shp.  Change the directory path and/or

theme name in the Geocode Theme window.
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The Geocoding Preferences button regulates the sensitivity to

spelling for the matches.  To increase the likelihood of the

match, decrease one of the scales: spelling sensitivity,

minimum match score, or minimum candidate score.  Note

that setting lower sensitivities can possibly introduce greater

error in your analysis, even though the likelihood of

matches would increase.

Matching
Using Batch Match
To match all addresses in your address table at once,

Ø Click on Batch Match (Geocoding Addresses window)

Ususally, a batch match is suggested in order to save time by matching the majority of matchable

addresses at one time.  Interactive Match is used for address tables that require special attention and

accuracy, matching each address individually.

After selecting the batch match button, ArcView matches the addresses in the address table to the

geocoded coordinates, placing a marker (a small dot by default) at the appropriate location.

Depending on the size of your table, this will take a few moments to complete.  When finished, a

Re-match Addresses window displaying the results of the geocoding will appear.  This window

displays the matching scores for addresses that were fully matched, partially matched, or not

matched at all.  The match score is a number (0-100) based on: (1) street name spelling (2) street

address falling within the address range.  Thus, a full match is an address that is spelled exactly like a

street name in the street theme and has its street address number within the address range given in

the street network theme.  Good matches are scores from 75-100.  If the street name is mispelled,

the address could be a partial match (score less than 75) or remain umatched, depending on the

degree of the misspelled street name.  An addresses that is not similar in spelling to any street

names, or an address that does not fall within the specified address ranges of the street is

considered a no match (0 score).   
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v If all addressess were fully matched, select done.  The

Address Matching process is now complete.

v If you have partial matches or no matches, you can

either select done, then recheck your address table for errors

or select Interactive Re-match.

Using Interactive Re-match
Use Interactive Re-match to re-match partial matches or addresses that did not get matched.  After

selecting the Interactive Re-Match button, the Geocoding Editor window appears.  Each address is

displayed on the main line, separately.  Potential candidates are shown below the main line.  At the

left of each candidate is the matching score based upon similarity in address, street name, street

type, etc.

The primary matching criterion is street address, so if you have 457 East Main St, but there isn’t any

457 on East Main St., ArcView will miss the match altogether.  Depending on the level of accuracy

needed for your project, you can “force” a match.  If you know the street name is right, you can

adjust the block number until a match is found.  In the case above, the problem seems to be that

the address did not have a street type or suffix given.  Furthermore LaSalle is written as La Salle

(with a space) in the street database.  If you think it reasonable that the possible match given is in

fact the match for this address, click Match.  If you're not confident of this, go on to the next one
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by clicking Next or back by clicking Previous.  If your address was matched to what you believe to be

the wrong address click Unmatch.  Select the Edit Standardize button to manually type in changes. 

Show Candidates will display the new potential matches after any changes.  The Preferences button

controls the spelling sensitivity of the match. 

Finished Product
When satisfied with the matches, press the Done button.  ArcView then creates a new shapefile

theme for the matches.  When you return to View1, the new theme of addresses will present in the

legend (default name is geocd1.shp).  To display, click on the small box next to the theme name in

the Legend.  If necessary, the view is now ready to be printed or exported.

Changes in Spatial Data
You have now successfully taken a file of locations and linked it to a spatial network of geocoded

streets.  This linked information is now fixed.  If there are any geographically related changes

(additional addresses, new streets, etc) that come up, the address matching process (start with

Building the Geocoding Index) must be repeated. 
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Changing Non-spatial Data
To make alterations of non-spatial (sales figures, population estimates, etc) attributes:

Ø Activate the new theme (double click on the theme name in the legend)

Ø Open the table by double clicking

Ø Choose Table> Start Editing

Edit your table as necessary.  When you are finished,

Ø Choose Table>Stop Editing

A window will ask you to save edits, select Yes.

Hopefully, your final view looks something like this:

An example of a final view of matched addresses.

Additional Resources
For further help, look to:

v Chapter 26 of Getting to Know ArcView Gis published by ESRI (1997)

v Chapter 2, of Inside ArcView GIS by Scott Hutchinson and Larry Daniel (1997)

Both books are available in the Geostat Reference section.      

Good Luck!
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